const regex = /<cuepoint(?=.* time="(\d{2}:[0-5]\d:[0-5]\d\.\d{3})")(?=.* type="(\w+)")(?=(?:.* end\-time="(\d{2}:[0-5]\d:[0-5]\d\.\d{3})")?)[^\/]*\/>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<cuepoint(?=.* time="(\\d{2}:[0-5]\\d:[0-5]\\d\\.\\d{3})")(?=.* type="(\\w+)")(?=(?:.* end\\-time="(\\d{2}:[0-5]\\d:[0-5]\\d\\.\\d{3})")?)[^\\\/]*\\\/>', 'gm')
const str = `<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<mediacaster version="1.1.0">
<cuepoints>
<cuepoint time="00:00:15.000" type="midroll_1"/>
<cuepoint type="midroll_1" time="00:00:15.000" />
<cuepoint end-time="00:07:36.963" time="00:07:27.194" type="midroll_overlay_1" />
<cuepoint time="00:07:27.194" end-time="00:07:36.963" type="midroll_overlay_1" />
</cuepoints>
</mediacaster>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}