re = /(?:chapter|ch.*?)(\d+\.?\d?(?:[-_]\d+)?)|(\d+\.?\d?(?:[-_]\d+)?)$/m
str = 'the-best-manga-volume-1-chapter-121_5
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end