re = /[^(\\'\/\\:\\*\\?\"\\<\\>\\|)]+/
str = 'sdsdsdsd.,./.;\';;*&ˆ%$#%$ˆ&*()_sddads<>?":||"|"|:ssadasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end