use strict;
my $str = 'define host {
use host-template
host_name server-01
display_name server-01-display-name
address 10.0.0.1
_CUSTOMEREMAIL customer01@mail.com
_LBZ LBZ#10178541
}
define service {
use host-template
host_name server-02
service_description server-02
servicegroups wlan
display_name server-02
_LBZ LBZ#425964
_TARGETIP 10.0.0.2
_CUSTOMEREMAIL customer5@mail.com
}
define service {
use host-template
host_name server-03
service_description server-03
servicegroups wlan
display_name server-04
_LBZ LBZ#421264
_TARGETIP 10.0.0.3
_CUSTOMEREMAIL customer01@mail.com
}
define host {
use host-template
host_name server-04
display_name server-04
address 10.0.0.4
_CUSTOMEREMAIL customer02@mail.com
_LBZ LBZ#12300541
}';
my $regex = qr/{(?=[^}]*?host_name\s*([^\s]+))(?=[^}]*?_LBZ\s*LBZ#(425964))(?=[^}]*?_TARGETIP\s*([^\s]+))/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}