$re = '/(?<=:")[^".]+\.[^".]+/';
$str = '"matchVersion":"6.22.165.3566"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);