re = /^\s*require.*/m
str = 'require(\'some/path/to/file.less);
...
// require(\'some/path/to/file.less);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end