import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<recode>([^#]*?)<\\/sumfa>";
final String string = "<item>\n"
+ " <imd>\n"
+ " <fs_ar>T</fs_ar>\n"
+ " <fs_as>T</fs_as>\n"
+ " <fs_af>T</fs_af>\n"
+ " <fs_aic>T</fs_aic>\n"
+ " <fs_air>T</fs_air>\n"
+ " <kid>601</kid>\n"
+ " </imd>\n"
+ " <title>whatever</title>\n"
+ " <recode>200</recode>\n"
+ " <reto>312</reto>\n"
+ " <doto>312</doto>\n"
+ " <pathrela>whatever.html</pathrela>\n"
+ " <realext>.php</realext>\n"
+ " <kindext>.html</kindext>\n"
+ " <charset>iso-8859-1</charset>\n"
+ " <mime>text/html</mime>\n"
+ " <sizeex>5633</sizeex>\n"
+ " <sizeco>T</sizeco>\n"
+ " <impsco>1.602941</impsco>\n"
+ " <impscosca>1.455153</impscosca>\n"
+ " <chgscosca>1.455153</chgscosca>\n"
+ " <lkstae>1</lkstae>\n"
+ " <lnkta>3</lnkta>\n"
+ " <sumfa>1</sumfa>\n"
+ " </item>\n"
+ " <item>\n"
+ " <imd>\n"
+ " <fs_ar>T</fs_ar>\n"
+ " <fs_as>T</fs_as>\n"
+ " <fs_af>T</fs_af>\n"
+ " <fs_aic>T</fs_aic>\n"
+ " <fs_air>T</fs_air>\n"
+ " <kid>23</kid>\n"
+ " </imd>\n"
+ " <title>Whats UP Dog</title>\n"
+ " <recode>200</recode>\n"
+ " <reto>219</reto>\n"
+ " <doto>219</doto>\n"
+ " <pathrela>wud.html</pathrela>\n"
+ " <realext>.html</realext>\n"
+ " <kindext>.html</kindext>\n"
+ " <charset>iso-8859-1</charset>\n"
+ " <mime>text/html</mime>\n"
+ " <sizeex>6252</sizeex>\n"
+ " <sizeco>T</sizeco>\n"
+ " <lastmo>2013-04-18 08:51:58</lastmo>\n"
+ " <impsco>398.818604</impsco>\n"
+ " <impscosca>9.11296</impscosca>\n"
+ " <chgscosca>8.657311</chgscosca>\n"
+ " <lksta>2</lksta>\n"
+ " <lkstae>8</lkstae>\n"
+ " <lnkta>414</lnkta>\n"
+ " <sumfa>1</sumfa>\n"
+ " </item>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}