$re = '/^([a-z]+(?:\s+[a-z]+)?)\s+([0-9]+)\s+([a-z]+(?:\s+[a-z]+)?)\s+([0-9]+)$/im';
$str = 'Word 123 Word 456
Word 1234 Word Word 3456
Word Word 3455 Word 4566
Word Word 4434 Word Word 44332';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);