re = /<node(\d)>(.*?)<\/node\1>/m
str = '<node1>xxxxxxx<x> xxx</node1>xxx xx</x>x x x xxxxxx <node2>xx x x xxxxxxxxxx</node2> xxxxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end