#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^.*?((?:[A-Za-z]+_)+[A-Z]\w+)(?:-([0-9]{8}-[0-9]{6})-([0-9]{8}-[0-9]{6}))?)"
Local $sString = "mixexecutor:check_atom_exists:740 - requested to check this machine : ET_colBackDDW_Temp " & @CRLF & _
"" & @CRLF & _
"output_of_reports/PII/36478_ABP_BAL_liquidpressure-20210831-123456-20210831-172355.bat.yz" & @CRLF & _
"" & @CRLF & _
"packofexecutors:_to_signle_que:869-no mata for file'/private/external_control_time_mapped_low_volume/IBA/54378_BD-RT_69-1-1-20200831-152355-20200831-172355.dat.xz'" & @CRLF & _
"" & @CRLF & _
"packofexecutors:_to_signle_que:869-no mata for file'/private/external_control_time_mapped_low_volume/IBA/54378_BD-RT_69-1-20200831-152355-20200831-172355.dat.xz'" & @CRLF & _
"" & @CRLF & _
"mixexecutor:check_atom_exists:740 - requested to check this machine : Eanes_colBack12_current" & @CRLF & _
"" & @CRLF & _
"packofexecutors._check_tar.587-nr of missed files=78 nr of skipped records=6547 nr of records not exist=0" & @CRLF & _
"" & @CRLF & _
"packofexecutors._filter_mistacl_signals:777 - invalid atomname for RT_6:ESmotormeaninfAmkl"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")