package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[(6011|65|64[4-9]|622)(\d{1,4})]{16}$`)
var str = `6221261418731541`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}