package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b\d+(?:\.\d+)?[a-z]*(?:-\w+)*`)
var str = `Examplestreet 1/2.1/3a/10/10.1/11b/12a-12c/13a-c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}