package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)^(.+)\.`)
var str = `
Line 1
מתני' השותפין. כולה נזיקין חדא מסכתא היא כדאמרינן בהגוזל קמא (ב"ק דף קב.) ובפ"ק דע"ז (דף ז.) ואפי' לא הוי חדא מסכתא צריך לפרש למה נשנית מסכתא זו אחר ב"מ כדאשכחן דדייק גמ' בריש מס' שבועות (דף ב:) מכדי תנא ממכות סליק מ"ש דקתני שבועות וכן בכמה מקומות והא דאמר (ב"ק קב.) בתרי מסכתות אין סדר למשנה היינו לענין מחלוקת ואח"כ סתם משום דרבי לא שנה לתלמידיו כסדר המסכתות ופעמים שנה האחרונה קודם הראשונה ואור"י דהיינו טעמא משום דקאי אהך פירקא דלעיל (ב"מ דף קטז:) הבית והעלייה של ב' שנפלו חולקים בעצים וכו' וקרי להו התם בגמ' שותפין וקתני נמי (שם דף קיח:) ב' גנות זו ע"ג זו וירק בינתים דהוי ענין שותפות:
כפיסין. מפרש בגמ' ארחי וקשה לר"י והכתיב (חבקוק ב) וכפיס מעץ יעננה משמע שהוא של עץ ואור"י דשמא היו מניחין עצים מלמעלה ומלמטה:
Line 2
בגויל זה נותן ג' טפחים כו'. והא דלא קאמר בגויל ו' טפחים משום דלא נטעי למימר ו' לכל אחד וא"ת אמאי אצטריך למיתני מדת גויל וגזית כיון דתנן הכל כמנהג המדינה כמו שנהגו כן יעשו וי"ל דאם נהגו יותר מו' בגויל לא יעשה וכן כולם אלא כשיעור המפורש ומיהו אם נהגו לעשות פחות מו' יעשה דאפילו אם נהגו בהוצא ודפנא יעשה כדמפרש בגמרא וא"ת ומאי בעי בגמ' הכל כמנהג המדינה לאתויי מאי ומשני לאתויי אתרא דנהיגי בהוצא ודפנא לימא לאתויי כמנהג כל המקומות כמו שנהגו ונראה לר"ת דדוקא בהוצא ודפנא אבל פחות מכאן אפילו נהגו מנהג הדיוט הוא ומוכיח מכאן דיש מנהגים שאין לסמוך עליהם אפילו היכא דתנן הכל כמנהג המדינה:
לפיכך אם נפל הכותל וכו'. פי' לפי שבונים הכותל בעל כרחם או משום דהקנו זה לזה לעשות גודא ללישנא קמא וכגון דידוע לנו עדיין וזוכרים שהקנו זה לזה וללישנא בתרא משום היזק ראיה וא"ת ומאי איריא משום דבונין הכותל בעל כרחם בלאו הכי נמי הוי של שניהם אפי' נפל לרשותא דחד מינייהו כיון דאין חזית לא לזה ולא לזה כדפריך בגמרא גבי בקעה לא יעשה חזית לא לזה ולא לזה ואי הוה דהאיך דנפל לרשותו מאי פריך הא צריך לעשות חזית שלא יפול לרשות אחר ויאמר שלו הן והא דאמרינן בהשואל (ב"מ דף ק.) גבי מחליף פרה בחמור וכן בריש הבית והעלייה (שם דף קטז:) וליחזי ברשות דמאן קיימא וליהוי אידך המוציא מחבירו עליו הראיה היינו משום דהתם מתחילה מבורר היה הדבר וברשות אחד מהן נולד הספק אבל הכא מעיקרא נולד הספק ואם היו באין לחלוק בעוד שהכותל קיים היו חולקין בשוה מספק אפילו לרבנן דסומכוס דלית להו ממון המוטל בספק חולקין הכא מודו כיון דליכא הכא חזקה לזה יותר מלזה הילכך אפילו נפל לרשותא דחד מינייהו לא יפסיד האחר כחו והא דלא אמר הכא כל דאלים גבר כמו בזה אומר של אבותי (לקמן דף לד:) התם הוא דליכא דררא דממונא אבל הכא איכא דררא דממונא ומתרץ ר"י דהיינו הך דפריך בגמרא פשיטא כדפירש בקונטרס דאפילו לא פסיק לן דינא דמתניתין שמתחילה בין שניהם עשאוה בעל כרחם היו חולקין בשוה ואפילו דנפל לרשותא דחד מינייהו כדמוכח גבי בקעה ומשני לא צריכא דנפל לרשותא דחד מינייהו פירוש ושהו ברשותו הרבה מהו דתימא כיון דשהו ברשותו הרבה ניהמניה שעשאוה כולה מיגו דאיבעי אמר ממך לקחתיה והיה נאמן משום דשהו הרבה ואף על גב דאמר בריש הבית והעלייה דשותפין לא קפדי אהדדי הכא מיירי דשהו יותר מכדי רגילות דאטו משום דשותפין נינהו לא יקפידו עד עולם ולא דמי לגודרות דאין להם חזקה (לקמן דף לו.) לפי שאין ידוע ביד מי הם אבל הכא לא היה לו להשהותו כל כך ברשותו קמ"ל כיון דמעיקרא על שניהם היה לעשות לא מהימן לומר שהוא עשה הכל דמיגו במקום עדים הוא דאנן סהדי שלא עשאה לבדו כיון שהיה יכול לדחוק את חבירו בדין שהיה עושה עמו אבל בבקעה אם שהו הרבה היה נאמן לומר שעשאה במיגו דאי בעי אמר לקחתיה והאי שינויא אינו אלא מאבנים אבל מקום הכותל לעולם פשיטא שחולקין אותו ואיידי דנקט אבנים נקט המקום:
Line 3
Line 4
Line 5
Line 6
סברוה מאי מחיצה גודא. אע"ג דלבסוף קאי קאמר סברוה לפי שזה הלשון אינו עיקר מחמת פירכא דלקמן ודיחוי בעלמא הוא האי דמשני וכלשון שני הלכה וכן פוסק ר"ת ואגב דנקט בהאי לישנא סברוה נקט נמי בלישנא אחריתי ועוד אור"י דבפרק קמא דנדרים (דף יא.) איכא סברוה אע"ג דלבסוף קאי ומסיק הכי:
כדתניא מחיצת הכרם שנפרצה. יש ספרים דגרסי דתנן ואומר ר"ת שאינה משנה בשום מקום (וא"כ) היכי פשיט מינה בהגוזל קמא (ב"ק דף ק. ושם) דר"מ דאין דינא דגרמי ואם היתה משנה הוה אתי שפיר דסתם משנה ר"מ היא ואומר ר"ת דמשמע ליה דאתיא כר"מ מכח מתניתין דכלאים דמייתי התם המסכך [את] גפנו על גבי תבואתו של חבירו [ה"ז] קידש וחייב באחריותו וההיא סתם משנה היא הילכך ההיא נמי דקתני קידש רבי מאיר היא ואין להאריך כאן יותר:
אומר לו גדור. פירוש לבעל הכרם והוא המזיק דארבע אמות שאמרו להרחיק הוא בשביל עבודת הכרם כדאמרי' בפ' שני לקמן (דף כו.) ואפילו ר' יוסי דקאמר לקמן (דף יח: כה:) על הניזק להרחיק את עצמו האמר רב אשי לקמן (דף כה:) מודי ר' יוסי בגירי דיליה ואומר ר"י דלהכי קתני אומר לו גדור ולא קתני חייב לגדור לפי שצריך להתרות בו ואם לא התרו בו לגדור אינו חייב באחריותו ולהכי נקט נמי תרי זימני נפרצה אומר לו גדור אף פעם שניה כשנפרצה צריך להתרותו שאינו סבור להיות חייב לגדור כל שעה ונפרצה פעם שלישית מספקא לר"י אם צריך להתרותו כל שעה או שמא סגי בתרי זימני ואין צריך להתרות בו יותר ור"ת מפרש דלהכי נקט תרי זימני לאשמועינן שאם יש תוספת מאתים בין מה שהוסיף בנפרצה ראשונה ובין מה שהוסיף בנפרצה שניה דאין מצטרפין לאסור ומראשונה ראשונה בטלי והארכתי בהגוזל קמא (ב"ק דף ק: ושם) ובפרק במה אשה (שבת דף סה.):
Daf 2b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}