const regex = /^rgba[(](?:\s*0*(?:\d\d?(?:\.\d+)?(?:\s*%)?|\.\d+\s*%|100(?:\.0*)?\s*%|(?:1\d\d|2[0-4]\d|25[0-5])(?:\.\d+)?)\s*,){3}\s*0*(?:\.\d+|1(?:\.0*)?)\s*[)]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^rgba[(](?:\\s*0*(?:\\d\\d?(?:\\.\\d+)?(?:\\s*%)?|\\.\\d+\\s*%|100(?:\\.0*)?\\s*%|(?:1\\d\\d|2[0-4]\\d|25[0-5])(?:\\.\\d+)?)\\s*,){3}\\s*0*(?:\\.\\d+|1(?:\\.0*)?)\\s*[)]$', 'gm')
const str = `#0F0F0F
#123
#1234
#ABC456
#1234567
rgb(1,2,3)
rgb(1,2,)
rgb(112233)
rgb(255,249,199)
rgb(256,249,199)
rgb(255,249,199,)
rgb( 100%, 199, 50%)
rgb( 100%, 199%, 50%)
rgb(1,2,3%,.5)
rgba(1,2,3%,0.75)
rgba(1,2,3%,.5)
rgba(1,2,.5)
rgba(1,2,3)
rgba(1,249,100,1)
rgba(1,249,100,1.0)
rgba(1,249,100,1.1)
rgba(255,256,255,1)
rgba(1,249.5,100%,1)
rgba(1,249.5,101%,1)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}