import re
regex = re.compile(r"^(?:#(?:[A-Fa-f0-9]{3}){1,2}|(?:rgb[(](?:\s*0*(?:\d\d?(?:\.\d+)?(?:\s*%)?|\.\d+\s*%|100(?:\.0*)?\s*%|(?:1\d\d|2[0-4]\d|25[0-5])(?:\.\d+)?)\s*(?:,(?![)])|(?=[)]))){3}|hsl[(]\s*0*(?:[12]?\d{1,2}|3(?:[0-5]\d|60))\s*(?:\s*,\s*0*(?:\d\d?(?:\.\d+)?\s*%|\.\d+\s*%|100(?:\.0*)?\s*%)){2}\s*|(?:rgba[(](?:\s*0*(?:\d\d?(?:\.\d+)?(?:\s*%)?|\.\d+\s*%|100(?:\.0*)?\s*%|(?:1\d\d|2[0-4]\d|25[0-5])(?:\.\d+)?)\s*,){3}|hsla[(]\s*0*(?:[12]?\d{1,2}|3(?:[0-5]\d|60))\s*(?:\s*,\s*0*(?:\d\d?(?:\.\d+)?\s*%|\.\d+\s*%|100(?:\.0*)?\s*%)){2}\s*,)\s*0*(?:\.\d+|1(?:\.0*)?)\s*)[)]|transparent|aqua(?:marine)?|azure|beige|bisque|black|blanchedalmond|blue(?:violet)?|(?:alice|dodger|cadet|midnight|powder|royal|sky|slate|steel)blue|(?:rosy|saddle|sandy)?brown|burlywood5|chartreuse|chocolate|coral|corn(?:flowerblue|silk)|crimson|cyan|dark(?:(?:slate)?blue|cyan|goldenrod|(?:olive|sea)?green|(?:slate)?gr[ae]y|khaki|magenta|orange|orchid|red|salmon|turquoise|violet)|deep(?:pink|skyblue)|firebrick|fuchsia|gainsboro|gold(?:enrod)?|(?:dim|slate)?gr[ae]y|(?:forest|lawn|spring)?green|greenyellow|honeydew|indigo|ivory|khaki|lavender(?:blush)?|lemonchiffon|light(?:(?:sky|steel)?blue|coral|cyan|goldenrodyellow|(?:slate)?gr[ae]y|green|pink|salmon|seagreen|yellow)|lime(?:green)?|linen|magenta|maroon|medium(?:aquamarine|(?:slate)?blue|orchid|purple|s(?:ea|pring)green|turquoise|violetred)|mintcream|mistyrose|moccasin|navy|oldlace|olive(?:drab)?|orange(?:red)?|orchid|pale(?:goldenrod|green|turquoise|violetred)|papayawhip|peachpuff|peru|(?:hot)?pink|plum|purple|(?:indian)?red|salmon|sea(?:green|shell)|sienna|silver|snow|tan|teal|thistle|tomato|turquoise|violet|wheat|whitesmoke|(?:antique|floral|ghost|navajo)?white|yellow(?:green)?)$", flags=re.MULTILINE)
test_str = ("#0F0F0F\n"
"#123\n"
"#1234\n"
"#ABC456\n"
"#1234567\n"
"rgb(1,2,3)\n"
"rgb(1,2,)\n"
"rgb(112233)\n"
"rgb(255,249,199)\n"
"rgb(256,249,199)\n"
"rgb(255,249,199,)\n"
"rgb( 100%, 199, 50%)\n"
"rgb( 100%, 199%, 50%)\n"
"rgb(1,2,3%,.5)\n"
"rgba(1,2,3%,0.75)\n"
"rgba(1,2,3%,.5)\n"
"rgba(1,2,.5)\n"
"rgba(1,2,3)\n"
"rgba(1,249,100,1)\n"
"rgba(1,249,100,1.0)\n"
"rgba(1,249,100,1.1)\n"
"rgba(255,256,255,1)\n"
"rgba(1,249.5,100%,1)\n"
"rgba(1,249.5,101%,1)\n"
"hsl(360,2%,100%)\n"
"hsl(361,2%,100%)\n"
"hsl(,2%,100%)\n"
"hsl(360,2%,)\n"
"hsl(360,2%,0100.00%)\n"
"hsl(360,2%,101%)\n"
"hsla(180,2%,100%,0.5)\n"
"hsla(180,2%,100%,)\n"
"transparent\n"
"blue\n"
"palevioletred\n"
"lightyellow")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")