const regex = /(home|fire)(?!.*\1)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(home|fire)(?!.*\\1)', 'ig')
const str = `When Home is on fire go and dance in fire`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}