package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([A-Za-z_-]*)="(.*?)")`)
var str = `<DT><A HREF="http://www.tripadvisor.fr/ShowUserReviews-g187849-d646539-r137197174-Hotel_Paradiso-Milan_Lombardy.html" ADD_DATE="1441047526" LAST_MODIFIED="1441047526" ICON_URI="http://static.tacdn.com/favicon.ico" ICON="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAQCAYAAAAf8/9hAAABE0lEQVQ4jd2QMWrDMBiF36xCblDRniFbyeADVMRDQ3qA9gyeHLp56FI6FEoIZHDJZIM7GfEfoz6A1+4atOR1kY1jXOhY8sNb9Ok9Pf3Af54ZgKug2V9NcwA7AC0AjtQGNh+bXgGkAJ4BHAEwSwzZvpwoS0wXdAx30+BFNPHaScjAPFbUtVhrrSkidM6xrmtqrZklhlliOMUA3A+/8SUilKLkbmkoRUkR6SuLCPNiz9unG+bFvmPNMMA757iNY9aXF9zGMb33BOA7ZjYLXr+BZrMYsn4aay2l+uT76o5SVcMGtNbyUH5wmUY8lPlkg34H3nuKCJVSfYBS6oRN7QDhoAnVGgAPAL6DHkdsPTb/Nqugc54f+w3c0e+99WoAAAAASUVORK5CYII=">Je donnerais un zéro si je pouvais - Avis de voyageurs sur Hotel Paradiso, Milan - TripAdvisor</A>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}