$re = '/^(?=[A-Z]*[a-z])(?=[a-z]*[A-Z])[a-zA-Z]{8,20}$/m';
$str = 'AaAaAaAaA
aaaaaaaaA
AAAAAAAAA
aaaaaaaaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);