#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)Host:\s((?:\w+\s?)*\(\w+\))"
Local $sString = "[2014-12-31 21:00] Host: Word1 (LOCATION) [140.56 km] 38.582 ms" & @CRLF & _
"[2014-12-31 12:00] Host: Word1 Word2 (LOCATION) [76.50 km] 49.508 ms" & @CRLF & _
"[2014-12-31 12:00] Host: Word1 Word2 Word3 (LOCATION) [76.50 km] 49.508 ms" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")