$re = '/:\s*([^\s]+)/m';
$str = 'NAME: Colin AGE:20 EMAIL;TYPE=PREF,INTERNET:colin@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);