import re
regex = re.compile(r".*[\W](@(?=.{5,64}(?:\s|$))(?![_])(?!.*[_]{2})[a-zA-Z0-9_]+(?<![_.])).*", flags=re.MULTILINE)
test_str = ("Pattern should match all this lines :\n\n"
"Hi @username how are you?\n\n"
"Hi @username.how are you?\n\n"
"😉@username.\n\n"
"And should not match email like this:\n\n"
"Hi email to something@domain.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")