re = /(.*?,.*?),.*/m
str = 'Basic information, advanced information, super information, no information'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end