$re = '/(\[[^][]*]|\([^()]*\))|[\s-]+/m';
$str = 'Lee Jong-jae(Season1) Nam Sung-woo[1]';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;