$re = '/([^?]+)\??([^?]*)/';
$str = 'geg f834&%uh3?us7 G&^gb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);