re = /\((.*?)\)|{(.*?)}|\[(.*?)]/m
str = 'Financial Operations (Financing, Customer Payment, and Settlement (AR), Collaborative Financial Processing, Vendor Invoice Verification and Processing (AP),Bank processes and Relationship Management, Allocation of Shared Services), Accounting(Financial statements, General Ledger and Subledger, Revenue and Cost Accounting, Job and Product Accounting, Product and Service Costing ), Corporate Services (Real estate management, Travel management (TEAs), Treasury and finance management ) Human Resource Management (HR Strategy and Planning, Recruitment, Payroll, Compensation and Total Benefits, Employee Development ), Manufacturing and Logistics (Production planning, materials management, inventory management, order entry and processing, warehouse mgmt, transportation mgmt, project mgmt, plant maintenance, customer service mgmt)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end