$re = '~<p>(.+?)</p>~s';
$str = '<p>
Lorem ipsum
second line or
third one?
</p>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);