const regex = /(?<=<code>).*?(?=<\/code>)/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<code>).*?(?=<\\\/code>)', 'sg')
const str = `<h3>This is sample HTML Coding</h3>
<pre><code>
<html>
<body>
Hello World
</body>
</html>
</code></pre>
<h3>This is another sample HTML Coding</h3>
<pre><code>
<html>
<body>
Another Hello World
</body>
</html>
</code></pre>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}