const regex = /\<p\s+?\/\>[ ]?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<p\\s+?\\\/\\>[ ]?', 'g')
const str = `<?xml version="1.0" encoding="utf-8"?>
<Data>
<Text number="1">
<Title>Lazy dog jumper</Title>
<Description><arg format="x" /><p /> The quick <p /> brown fox <p /> jumps <p /> over the <p /> lazy dog.<p />The quick brown fox jumps <p />over the lazy dog.<p /> The quick brown fox jumps over the lazy dog. <p /></Description>
</Text>
<Text number="2">
<Title>Lazy foxer</Title>
<Description>The quick brown fox <arg format="x" /><p />jumps <p>asdf</p> over the lazy dog <p /></Description>
</Text>
<Text number="3">
<Title>Quickest jumper</Title>
<Description>The quickest brown fox jumps over the lazy dog <p /> The slowest brown fox jumps over the laziest dog. <p /></Description>
</Text>
</Data>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}