const regex = /\B(?=(\d{3})+(?!\d))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B(?=(\\d{3})+(?!\\d))', 'gm')
const str = `44444444444444444444444444444444444444444.4444444444444444`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);