$re = '/^(?!.*?\d{4}).+$/m';
$str = 'Stack254!
Stack254!36@
Stack8763^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);