$re = '/\b[\w\'\s]+?\bone\s?[\w\s]*?\./m';
$str = 'i have one treehouse. i\'m the one. I have two cats.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);