package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-\d+]+`)
var str = `10-20-30
100-200-300-400
10-20-30-40-50 ffff
10-20-30-40-50`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}