# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+:)\s*\[(.+)\]\s*\n/$1 <b> |$2| <\/b><BR>\n/g;t' <<< "Sample Collection Date: [LL4HEMDT]
White blood cell count:[LL4WBRES]
Hemoglobin: [LL4HGRES]
Hematocrit: [LL4HMRES]
Red blood cell count: [LL4RBRES]
Platelets: [LL4PLRES]
Neutrophils: [LL4ANRES]
Lymphocytes: [LL4LCRES]
Monocytes: [LL4MORES]
Basophils: [LL4BARES]
Eosinophils: [LL4ECRES]
Immature granulocyte: [LL4IGRES]
Mean corpuscular volume: [LL4MVRES]
Mean corpuscular hemoglobin: [LL4MHRES]
Mean corpuscular hemoglobin concentration: [LL4MCRES]
Red cell distribution width: [LL4RDRES]
Sample Collection Date: [LL4CGBDT]
Prothrombin time: [LL4PTRES]
Partial thromboplastic time: [LL4PRRES]
International normalized ratio: [LL4NRRES]
"