using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(F: #|# F:) \{ blabla \}";
string input = @" F: # { blabla } or # F: { blabla } ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}