import re
regex = re.compile(r".*donotbackup.*")
test_str = ("donotbackup\n"
"test_donotbackup\n"
"donotbackup_test\n"
"test_donotbackup_test\n"
"TEST_DONOTBACKUP_TEST\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")