$re = '/\b(?:(cat)\s??\b){3}/';
$str = 'dog cat cat cat dog cat cat cat
cat cat cat
cat cat catdog
dogcat cat cat
cat cat
cat
catcatcat
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);