$re = '/.*Score \{\K\d+(?=})/s';
$str = 'I\'m looking for a specific text Score {123} in a file. I loaded the
file in a Score {234} variable and am searching in it through
RegExMatch. Since the Score {345} text I\'m looking for can be found
many times in the file, Score {456} I want to read the last ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);