// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\\x").unwrap();
let string = "callbackProxy({\"7103/usatoday/high_impact/entertainment/main\":{\"_type_\":\"html\",\"_expandable_\":false,\"_html_\":\"\\x3chtml\\x3e\\x3chead\\x3e\\x3cstyle\\x3e\\x3c!--\\na:link { color: #000000 }a:visited { color: #000000 }a:hover { color: #000000 }a:active { color: #000000 } --\\x3e\\x3c/style\\x3e\\x3cscript\\x3e\\x3c!--\\n(function(){var d\\x3d{};window.ss\\x3dfunction(a){void 0!\\x3d\\x3dd[a]?d[a]++:d[a]\\x3d1;var e\\x3ddocument.getElementById(a),b\\x3dd[a];if(window.css)css(a,\\x22nm\\x22,b,void 0,void 0)";
let substitution = "\\u00";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}