$re = '/"(?>[^",]*(?>,[^",]+)*)"/';
$str = '"animal,dog,cat","ecoli, verification,"streptococcus","","sdflkj,dlfkj,"sdlfkjsd,sdlkfj"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);