$re = '/^\/(.*\.php).*\.php$/m';
$str = '/xxx/newfile.php/core/test.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);