import re
regex = re.compile(r"[a-zA-Z\À-ž\d\s.',/-]", flags=re.MULTILINE)
test_str = ("- , . ' & /\n"
"abcdefghijklmopqrstuvwxyz \n"
"ABCDEFGHIJKLMNOPQRSTUVW\n"
"1234567890\n"
"_[]\"\\?<>!@#$%^*()\n"
"áäâàæãåāçéëêèęėēíïìîįīj́ñńóöôòõœøōúüûùū\n"
"ÁÄÂÀÆÃÅĀÇÉËÊÈĘĖĒÍÏÌÎĮĪJ́ÑŃÓÖÔÒÕŒØŌÚÜÛÙŪ\n\n"
"Paradijslaan\n"
"64\n"
"B\n"
"3034 SP\n"
"Rotterdam\n"
"Luxemburgstraat\n"
"41\n"
"A\n"
"1363 BK\n"
"Almere\n"
"Klarinet\n"
"6\n"
"5231 DL\n"
"'s-HertogenboschNoordstraat\n"
"42-a\n"
"5038 EJ\n"
"Tilburg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")