re = /^((?:~?\/)|(?:(?:\\\\\?\\)?[a-zA-Z]+\:))(?:\/?(.*))?$/m
str = '\\\\?\\ss:/sdfds/sdfsdf/sdfdsf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end