using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ATG((?:[ACTG]{3})+?)(?:TAG|TAA|TGA)";
string input = @"TTATGTTTTAAGGATGGGGCGTTAGTT
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}