using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\/(\w+)(?:\+(\w+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?(?:\s?;\s?(\w+)=([\w\.]+))?";
string input = @"application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello
application/xhtml+json; q=1000; level=4 , ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}