const regex = new RegExp('(?<=[\\\\\\/])[a-zA-Z\\-_]+$', 'gm')
const str = `/Hello/Stack/Overflow
/when/I/try/this
C:\\on\\VS_Code
C:\\it\\does\\not\\work
/can you
C:\\help\\me?
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}