package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`=(.*?)}`)
var str = `It was a {{color, default=black}} and scary {{phase}}. As the {{animals, default=dogs}} {{make_sound, default=barked}} and the trees swayed {{setting, default=to the breeze}}, a {{size, default=}} {{monster, default=troll}} that emerged from the shadows.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}