$re = '/[0-9]+/';
$str = '6546546546
65
654
645
64
6
5465
654
64
654
6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);