# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(AN|AA|AD|AE).*?(Jan|Feb|Mar|Apr|May|Jun|JUL|Aug|Sep|Oct|Nov|Dec)*([a-z]{3})([a-z]{3})|^FXD.*?([a-z]{3})([ ]*\/[ ]*[d,D]\d\d\w\w\w|[ ]*\/[ ]*[t,T][d,D]\d\d\d\d)*([a-z]{3})*([ ]*\/[ ]*[d,D]\d\d\w\w\w|[ ]*\/[ ]*[t,T][d,D]\d\d\d\d)*([a-z]{3})*"
test_str = ("fxdbom /d12augdel\n"
"FXD 4 JFKMIA\n"
"FXDJFK/ D15JUNMIA /D25JUNATL/D27JUNJFK\n"
"FXDJFK/D15JUN/TD0900MIA\n"
"FXD 2 PAR /D15JUNMIA //PB2500\n"
"FXD BOM /D12AUGDEL /D23SEPBOM\n"
"FXD BOM /D23AUGDEL /D24SEPBOM")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.