re = /myserver:\/\/(.*?)(?=myserver:\/\/|$)/
str = 'myserver://password,123@ip:port/key1,myserver://pass2@ip2:port2/key2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end