const regex = /(?<!\blearn.+?)\bwrite a regex\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\blearn.+?)\\bwrite a regex\\b', 'g')
const str = `"I'm learning how to write a regex" (should not match)
"I know how to write a regex" (should match)
"I know how to read an write a regex" (should match)
"I want to know how to write a regex" (should match)
"I want to learn how to write a regex" (should not match)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}